Jump to content


Photo

[BFME1/BFME2/ROTWK] Games Download & Installation Guide


  • Please log in to reply
390 replies to this topic

#381 Estevezz01

Estevezz01
  • New Members
  • 2 posts

Posted 28 December 2017 - 10:13 PM

also i have a windows 10 laptop



#382 MattTheLegoman

MattTheLegoman

    LEGO Knight of Minas Ithil

  • T3A Staff
  • 3,351 posts
  • Location:Tomorrow, when the War began
  • Projects:Mapping this Middle-earth
  •  Mapper
  • Division:BFME
  • Job:T3A Staff

Posted 29 December 2017 - 02:51 PM

Try downloading the patches manually.

Remember that all worlds draw to an end and that noble death is a treasure which no one is too poor to buy. - C.S. Lewis

There will come a time when you believe everything is finished. That will be the beginning. - Louis L'Amour

What will matter then will be people. If relationships will matter most then, shouldn't they matter most now? - Max Lucado


#383 noblanqgg

noblanqgg
  • New Members
  • 1 posts

Posted 30 December 2017 - 09:05 PM

Hey guys,

sorry for my bad english

 

Today I installed BFME 1, 2 and RotWK following these steps. BFME1 worked perfectly on first try but BFME2 and RotWK are stopping working since it opens

 

Tried almost everything: Options.ini problem, launch as admin, some fixers, etc...

 

Tried too ran windows 10 on safe mode, there the game opens normally

 

 

My windows 10 is x64 with AMD RX 550



#384 Flashedmind

Flashedmind
  • Members
  • 5 posts

Posted 31 December 2017 - 09:09 AM

It seems like the AMD drivers aren't compatible, as stated by a guy on page 19 

 

Edit: SOME drivers


Edited by Flashedmind, 31 December 2017 - 09:09 AM.


#385 Capy

Capy
  • New Members
  • 1 posts

Posted 03 January 2018 - 02:42 AM

Everything went perfectly fine except for the very last part involving the Witch King expansion. After I installed the 2.02 patch and tried launching it I get a crash and an error message that looks like this:

 

5UxekEI.png

 

Any ideas what went wrong/what I may have done wrong?

 

Edit: I fixed it the day after. I never got the 2.01 patch before 2.02 so I did that now and also switched the bfm2 patch from 1.9 to 1.6 wich made it work.


Edited by Capy, 03 January 2018 - 12:31 PM.


#386 ICT

ICT

    -

  • Division Admins
  • 2,965 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 03 January 2018 - 03:59 PM

Set bfme2 to patch 1.06, not 1.09.

"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#387 goldensoul

goldensoul
  • Members
  • 22 posts

Posted 13 January 2018 - 08:25 AM

So why do you not tell people to use the Origin version of RotWK?

 

It's free if you have a valid key and it works without a disc (or image) and also without the Origin Client running. All you need is to download through Origin and then authenticate at first start with your Origin account details.

 

the Origin version of RotWK is 2.00 version and cannot be updated to new version, if u do, u will lost your nocd.



#388 matt125

matt125
  • New Members
  • 2 posts

Posted 17 January 2018 - 11:14 PM

 Hi!

 

I am trying to download the 2.02 patch of RotWK and have followed your directions closely. However, I get this error screen when I start the program. The error says:

 

"Program: ...e Lord of the Rings, The Rise of the Witch-king\game.dat

 

 

 

This application has requested the Runtime to terminate it in an an unusual way.

Please contact the application's support team for more information."

 

I have windows 10 if it means anything and have reinstalled the game three times now, avoiding the mini images mounting and the 2.01 origin update that I did the previous times. I am also running bfme2 on 1.06 as needed. Can you tell me what I am doing wrong? Thanks.


Edited by matt125, 17 January 2018 - 11:26 PM.


#389 ICT

ICT

    -

  • Division Admins
  • 2,965 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted Yesterday, 09:21 AM

Does the normal game run fine without community patches or our launcher? Bfme2 works too?

"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#390 matt125

matt125
  • New Members
  • 2 posts

Posted Yesterday, 01:09 PM

So Bfme2 works totally fine. I used this install guide to do everything: https://www.gamerepl...owtopic=1000430 (in case there is some file issues on bfme2's side). I also use the bfme2 patch switcher to go between the 1.06 and 1.09 updates.

But RotWK doesn't work through any of the community patches. When I run the base game, it simply says to insert the CD to start the game. I did use WinCDEmu to mount everything if it makes any difference.


Edited by matt125, Yesterday, 01:11 PM.


#391 ICT

ICT

    -

  • Division Admins
  • 2,965 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted Yesterday, 01:41 PM

Install the latest rotwk community patch and make sure it replaces the game.dat. You might have to do that yourself. Afterwards it should not ask for the CD anymore.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users