Do you have any older versions too? Having the newest one isn't always enough, because they are pretty much separate things.
I think the launcher specifically needs 3 or 3.5 version. If you don't have them, you should still be able to install it even if you have 4.0.
I think 2.0 is used and not 3. 3.5 is backwards compatible with 3.0 tho, so 3.0 isn't needed ever in these days.