Jump to content


Photo

[BFME2] T3A:Online Installation Support

bfme2

  • Please log in to reply
458 replies to this topic

#441 Darthsider

Darthsider
  • Members
  • 7 posts

Posted 20 March 2018 - 11:05 AM

 So , I tried to install the game from the beginning like the last time. I updated it with the patch version 1.06 then used the patch switcher to update it to 1.09. Then , I fixed the resolution to 1920x1080 again. Still , I couldn't make it to the main menu.  It crashed.


Edited by Darthsider, 20 March 2018 - 11:06 AM.


#442 ICT

ICT

    -

  • Veterans
  • 3,071 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 20 March 2018 - 12:11 PM

What exactly is the problem?

 

Do you have an options.ini file? Did you install the new game.dat?


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#443 Darthsider

Darthsider
  • Members
  • 7 posts

Posted 20 March 2018 - 12:31 PM

Yeah , I do have the Options.ini file. I did but it made no difference. : (



#444 Darthsider

Darthsider
  • Members
  • 7 posts

Posted 20 March 2018 - 12:44 PM

 The problem is everytime I can make it to the main menu , I have to install the Asset files from its program into the game directory and set the Options.ini  to very low settings and the resolution to 800x600. Yet , I can't play any mode ; Tutorials , Skirmish , War of the Ring and My Heroes. The game still crashes after successfully passing the loading screen.


Edited by Darthsider, 20 March 2018 - 01:02 PM.


#445 ICT

ICT

    -

  • Veterans
  • 3,071 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 20 March 2018 - 12:52 PM

I have no idea what you are doing. Did you install a mod or something?


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#446 Darthsider

Darthsider
  • Members
  • 7 posts

Posted 20 March 2018 - 02:05 PM

   Before I installed this  Assets files' program , I hadn't used any mod on the game. Without it , the game still stopped running in the black screen.It's kinda weird.



#447 ICT

ICT

    -

  • Veterans
  • 3,071 posts
  •  -- MOC --
  • Division:BFME
  • Job:Online Admin

Posted 20 March 2018 - 02:12 PM

I have no idea what 'assets files program' is. Get rid of it if it's causing trouble.


"To know what question we may reasonably propose is in itself a strong evidence of sagacity or intelligence. For if a question be in itself incongruous and begs for uncalled-for answers, it holds, sometimes, besides embarrassing the proposer, the disadvantage to seduce the unguarded listener into giving absurd answers, and we are presented with the ridiculous spectacle of one (as the ancients said) milking the he-goat, and the other holding a sieve beneath."


#448 Darthsider

Darthsider
  • Members
  • 7 posts

Posted 20 March 2018 - 02:22 PM

Okay. Thank you for replying. I will vanquish it and do the  game installation once more. 



#449 GalPaladin

GalPaladin
  • New Members
  • 2 posts
  • Location:U.S. Pacific Coast

Posted 03 July 2018 - 10:10 AM

I couldn't get through all 23 pages, it was a bit daunting, so my apologies if this came up before. I'm running BFME II in the original CD version in Windows 7. Everything is working properly, including the Patch Switcher. However, when trying to get the T3A: Online application to work, I'm running into a wall and feel like I'm missing something simple.

 

I'm simply getting the error: "Unable to launch BFME2".

 

Any ideas? Preferably, "You overlooked this incredibly obvious thing, go fix it in 5 seconds and don't you feel silly now?"



#450 GalPaladin

GalPaladin
  • New Members
  • 2 posts
  • Location:U.S. Pacific Coast

Posted 03 July 2018 - 10:15 AM

Mmk. I didn't have the T3A launcher running as admin. I overlooked this incredibly obvious thing, fixed it in five seconds, and feel silly. Thanks! :D



#451 Foe_Hammer

Foe_Hammer
  • New Members
  • 1 posts

Posted 13 July 2018 - 08:42 PM

Trying to play ROTWK online and I get "failed to join - game is a different version" error. My BFME2 patch is 1.06. My rotwk patch is 2.02v7. I'm using the no-cd game.dat for bfme2. I got the same error using the original game.dat folder. As far as I can tell everything is up to date. I know I've added the options.ini folder to fix the crash on startup problem so maybe I need a different one? I have NEVER been able to play this game online but I've played it offline since 2006 and I'd really like to play online so any help would be greatly appreciated, thanks


Edited by Foe_Hammer, 13 July 2018 - 08:43 PM.


#452 MasterofArda

MasterofArda
  • New Members
  • 4 posts

Posted 13 July 2018 - 08:45 PM

Foe_Hammer was my old account I somehow logged into. This is my new account for revora and bfme online



#453 Palaisy

Palaisy
  • Members
  • 5 posts

Posted 20 July 2018 - 01:04 AM

Hi i am trying to install the T3A launcher and gettting the Debugger to Key/software/microsoft/windowsNT/currentVersion.image file execution/Options/Lotrbfme.exe verify that you have access to that key



#454 ghettoceratops

ghettoceratops
  • New Members
  • 1 posts

Posted 05 August 2018 - 07:00 PM

Hey, im going to join the bandwagon on not being able to get Bfme2 to work correctly. I have downloaded teh Launcher, Bfme2, the patch switcher, I am clicking on the game and running as admin, but it still says that i nee to insert the CD OR if i run it through the launcher, it says that it is unable to launch. any help? 



#455 Ch4zzyCh4zz

Ch4zzyCh4zz
  • New Members
  • 2 posts

Posted 19 August 2018 - 04:12 PM

Talking about T3A launcher, is this a normal log file ? ( from %TEMP%\T3AOnline_Log.txt)


----- T3A:Online Launcher Start -----
Game: BFME2
BFME2 Install Path: C:\Program Files (x86)\Electronic Arts\La Bataille pour la Terre du Milieu II\
Started game with: "lotrbfme2.exe "
Caught CREATE_PROCESS_DEBUG_EVENT from BFME2. Detaching...
Found game.dat process. PID 15780
*** Starting CA public key patching routine ***
CA public key is expected value.
Successfully patched CA public key.
*** Starting hostname hooking routine ***
Injecting DLL into game.dat process...
Result of injection: Code -1073741582
 
 
 
 
The negative code in the end really bothers me. Looks like an error code.
My game does just nothing when i enter my credentials in the Online section of the game.
Is there any other error log i could find?
 
W10, run as administrator. BFME2 patched 1.0.6.


#456 MrBenny

MrBenny
  • New Members
  • 3 posts

Posted 05 September 2018 - 10:20 PM

Hello I've been trying to install this game for a year now and I have been trying really hard recently.

I made a post on reddit that explains the situation better ---> https://www.reddit.c...he_game_but_im/

 

But basically I've tried everything to get it to work and I just can't. 

And when I say everything I really mean everything

 

My graphics card is an Intel HD Graphics 4400 and I'm running Windows 7

 

I've tried the most basic solutions and the most weirdest and got all sorts of errors but the most common is 2 or 3 windows of Fatal Errors that say "Exception in exception handler"

 

Please help, I've been trying for two straight days, the only thing that I got out of it was that I managed to get BFME 1 running which I couldn't.



#457 MattTheLegoman

MattTheLegoman

    LEGO Knight of Minas Ithil

  • T3A Staff
  • 3,458 posts
  • Location:Tomorrow, when the War began
  • Projects:Mapping this Middle-earth
  •  Mapper
  • Division:BFME
  • Job:T3A Staff

Posted 06 September 2018 - 12:23 AM

Try a different computer, it looks like you've already gone through with troubleshooting everything. Honestly, the fact that you mention an Intel graphics card makes me jump to conclusions and think that is probably the issue.

 

P.S. There's the options ini thing. Have you tried that?

 

And I just found this: https://www.reddit.c...he_game_but_im/


Edited by MattTheLegoman, 06 September 2018 - 03:44 AM.

Remember that all worlds draw to an end and that noble death is a treasure which no one is too poor to buy. - C.S. Lewis

There will come a time when you believe everything is finished. That will be the beginning. - Louis L'Amour

What will matter then will be people. If relationships will matter most then, shouldn't they matter most now? - Max Lucado


#458 MrBenny

MrBenny
  • New Members
  • 3 posts

Posted 06 September 2018 - 09:37 AM

Try a different computer, it looks like you've already gone through with troubleshooting everything. Honestly, the fact that you mention an Intel graphics card makes me jump to conclusions and think that is probably the issue.

 

P.S. There's the options ini thing. Have you tried that?

 

And I just found this: https://www.reddit.c...he_game_but_im/

 

Of course I tried the options.ini. Various times in different ways. I just think that this PC was able to run the game a few years ago and this is the only PC I have. I had a worse PC before and I could run the game just fine.



#459 jlx94

jlx94
  • New Members
  • 4 posts

Posted 14 September 2018 - 08:53 AM

Hello,
 
I'm installing and plying BFME* since 6 years now without any troubles. As I changed my coputer OS from Win7 to Win10 64bits, I reinstalled BFME I, and 2 but i'm facing a problem with the online mode in BFMEII. I nistalled the Special Forshire edition, and then patch 1.09 and then latest T3AOnline.
I'm launching game from the T3AOnline launcher (latest) and game is running fine , however, I could not see the revora/T3a login banner in the "online" section, I've only EA account registering available...

 

I tried with HD edition but it is claiming an update, and admin rights, to patch with an EA patch ....

I installed BFMEI before, and launching it with the same T3A wich is launching another t3a version behind, and then launching the game. In the BFMEI install I'm able to logon with revora Account....

Have any clue ? 
 
My t3a log is:

----- T3A:Online Launcher Start -----
Game: BFME2
BFME2 Install Path: e:\Games\EA GAMES\The Battle for Middle-earth II\
Started game with: "lotrbfme2.exe "
Caught CREATE_PROCESS_DEBUG_EVENT from BFME2. Detaching...
Found game.dat process. PID 14640
*** Starting CA public key patching routine ***
CA public key is expected value.
Successfully patched CA public key.
*** Starting hostname hooking routine ***
Injecting DLL into game.dat process...
Result of injection: Code -1073741582


----- T3A:Online Launcher Start -----
Game: BFME2
BFME2 Install Path: e:\Games\EA GAMES\The Battle for Middle-earth II\
Started game with: "lotrbfme2.exe "
Caught CREATE_PROCESS_DEBUG_EVENT from BFME2. Detaching...
Found game.dat process. PID 1464014640
*** Starting CA public key patching routine ***
ERROR: CA public key differs from expected value. Not patching.
ERROR: CA public key patching routine failed.

Thank's for the help


Edited by jlx94, 14 September 2018 - 08:55 AM.






Also tagged with one or more of these keywords: bfme2

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users